Rubygems 1.4 will not support Ruby 1.8.6

Eric Hodel writing a week or so ago:

Ruby 1.8.6 is old and it’s API is lacking the forward-compatibility that Ruby 1.8.7 has for moving to Ruby 1.9. Since I maintain two large ruby libraries that are shipped in 1.9 (RDoc and RubyGems) it is becoming hard to maintain 1.8.6 support inside them comfortably.

RubyGems 1.4.x will not support Ruby 1.8.6.

Seems eminently sensible.

Tags: , ,

Comments are closed.